I am sorry, but I just can't resist.
There are a few problems with this code:
* as pointed out by another replier, when passing parameter to the function (bool recommend), "bool" should be omitted, this won't compile
* why define a recommend variable, if it always is set to true, simply call forwardResumeToMicrosoft(true) instead
* Evil() function does not receive any parameters, so if we have to focus on the surveyResults variable. If this variable is a boolean, than why not simply compare it to true or false, or a global constant? If this variable is a number (indicating the survey score), then comparing it to a function that returns a number does not make sense - either compare it to a global constant of PURE_EVIL = -9 (for example), or pass the result into the Evil() method for valuation. Same logic applies to the variable if it is an object of some sort.
* and finally, what's with mixing notations - either use camel-case notation everywhere, or use capitals, why is surveyResults camel-case, and Evil() starts with a capital letter, notice that hire() method starts with a lower-case.
Well, now back to our every day problems.