Average Ratings 0 Ratings

Total
ease
features
design
support

No User Reviews. Be the first to provide a review:

Write a Review

Average Ratings 0 Ratings

Total
ease
features
design
support

No User Reviews. Be the first to provide a review:

Write a Review

Description

ContextForge MCP Gateway serves as an open-source platform that functions as a Model Context Protocol (MCP) gateway, registry, and proxy, offering a consolidated endpoint for artificial intelligence clients to find and utilize tools, resources, prompts, as well as REST or MCP services within intricate AI ecosystems. This solution operates in front of various MCP servers and REST APIs, facilitating federated and unified processes for discovery, authentication, rate-limiting, observability, and traffic management across numerous back-end systems, while accommodating multiple transport methods like HTTP, JSON-RPC, WebSocket, SSE, stdio, and streamable HTTP; it also has the capability to transform legacy APIs into MCP-compliant tools. Additionally, the platform features an optional Admin UI that enables users to configure, monitor, and access logs in real time, and it is architected to scale efficiently, from single-instance deployments to expansive multi-cluster Kubernetes setups, utilizing Redis for federation and caching to enhance both performance and resilience. In this way, the ContextForge MCP Gateway not only simplifies the interaction within complex AI architectures but also ensures robust functionality and adaptability across various operational environments.

Description

TekSIP for Windows is a SIP Registrar as well as a SIP Proxy. TekSIP supports UDP (IPv4 & IPv6), TCP (IPv4 & IPv6), TLS, and WebSocket transports. Only commercial editions support Secure WebSocket and TLS. TekSIP has been tested on Microsoft Windows Vista and Windows 7/8/10/11 servers. TekSIP is a signaling service for WebRTC based SIP-based phones. TekSIP is compliant with RFC 3261 and RFC 3263. It also complies to RFC 3581, RFC 3891, RFC 3311 and RFC 3481. It supports NAT traversal, ENUM. Please refer to Readme for technical details on NAT traversal. You can choose the IP address that will be listened to and alternative SIP endpoints when making outgoing calls. You can also log the session details in a log and monitor registrations and active sessions in real-time. Windows Performance Monitor (Perfmon.exe) allows you to monitor the number of active sessions and registrations. TekSIP redirects calls to an alternate endpoint if the called endpoint is not available (Offline, busy ...). GUI can be used to terminate an active SIP session.

API Access

Has API Yes 

API Access

Has API Yes 

Screenshots View All

Screenshots View All

Integrations

Claude Yes 
Docker Yes 
Hindsight Yes 
Jaeger Yes 
Kubernetes Yes 
Model Context Protocol (MCP) Yes 
OpenAI Yes 
Phoenix Yes 
PowerShell Yes 
PyPI Yes 
Python Yes 
SQLite Yes 
TekRADIUS No 
Zipkin Yes 

Integrations

Claude No 
Docker No 
Hindsight No 
Jaeger No 
Kubernetes No 
Model Context Protocol (MCP) No 
OpenAI No 
Phoenix No 
PowerShell No 
PyPI No 
Python No 
SQLite No 
TekRADIUS Yes 
Zipkin No 

Pricing Details

No price information available.
Free Trial No 
Free Version No 

Pricing Details

$239
Freeware version allows maximum 3 SIP endpoints registration and 3 simultaneous SIP sessions. Enterprise edition allows upto 100 simultaneous registration and SIP sessions. Following features are not supported in free edition;

Enterprise
* SDP Manipulation
* TLS Transport
* SMPP Gateway

SP
* Enterprise features
* External Authenticator
* SRTP -> RTP interworking
* WebRTC Media Gateway
* Unlimited number of simultaneous SIP registrations and sessions
* Route incoming calls to registered extensions
* IPv6 support
* RADIUS AAA
Free Trial Yes 
Free Version Yes 

Deployment

Web-Based No 
On-Premises No 
iPhone App No 
iPad App No 
Android App No 
Windows Yes 
Mac Yes 
Linux Yes 
Chromebook No 

Deployment

Web-Based No 
On-Premises Yes 
iPhone App No 
iPad App No 
Android App No 
Windows Yes 
Mac No 
Linux No 
Chromebook No 

Customer Support

Business Hours No 
Live Rep (24/7) No 
Online Support Yes 

Customer Support

Business Hours Yes 
Live Rep (24/7) Yes 
Online Support Yes 

Types of Training

Training Docs Yes 
Webinars No 
Live Training (Online) No 
In Person No 

Types of Training

Training Docs Yes 
Webinars No 
Live Training (Online) Yes 
In Person No 

Vendor Details

Company Name

IBM

Founded

1911

Country

United States

Website

ibm.github.io/mcp-context-forge/

Vendor Details

Company Name

KaplanSoft

Founded

2011

Country

Turkey

Website

www.kaplansoft.com

Product Features

Product Features

Telephony

Auto-Dialer No 
Call Center Management No 
Call Monitoring Yes 
Contact Management No 
IVR / Voice Recognition No 
Inbound Reporting No 
Outbound Reporting No 
Predictive Dialer No 
Telemarketing Management No 
VoIP Yes 
Voice & Data Integration Yes 

Alternatives

Alternatives

TekIVR Reviews

TekIVR

KaplanSoft
FastMCP Reviews

FastMCP

fastmcp