Average Ratings 0 Ratings
Average Ratings 0 Ratings
Description
Codayak is a complimentary desktop AI coding workbench designed for software developers and teams, particularly those working with .NET and Visual Studio. This tool meticulously analyzes repositories and their dependencies, transforming work items into user stories and acceptance criteria while also generating or amending code as needed. In addition, it facilitates project builds, runs unit tests, executes SQL queries across various databases such as SQL Server, PostgreSQL, MySQL/MariaDB, SQLite, and Oracle, and tests user interfaces on both browsers and Windows desktop environments. Furthermore, Codayak reviews pull requests on platforms like GitHub and Azure DevOps, enhancing the collaborative coding process. Its innovative Trust Engine evaluates builds for tests, security, style, and adherence to specifications, providing a trust band along with supporting evidence for developers. With options for backups and diffs, Codayak allows developers to scrutinize and revert changes with ease. Importantly, Codayak remains free for both personal and commercial use, eliminating the need for subscriptions or usage fees. It also integrates with your API keys for compatible language model providers or can operate with locally hosted models, with costs incurred solely for API usage from those providers. Overall, Codayak represents a robust solution for coding efficiency and reliability in software development.
Description
TekRADIUS for Windows is a RADIUS Server with a built-in DHCP Server. TekRADIUS has been tested on Microsoft Windows Vista and Windows 7-11 servers. TekRADIUS complies to RFC 2865 and RFC2866. TekRADIUS supports TCP (RFC 6613), and TLS (RFC 6614 - RadSec). TekRADIUS comes in three editions: TekRADIUS LT, which supports SQLite, and TekRADIUS OD, which supports MySQL, MariaDB and PostgreSQL databases via ODBC. It runs as a Windows Service, and comes with an interface for Windows management.
API Access
Has API
No
API Access
Has API
No
Integrations
Azure DevOps
Yes
Dynasoft Telefactura
No
GitHub
Yes
MariaDB
Yes
MySQL
Yes
Oracle Database
Yes
PostgreSQL
Yes
SQL Server
Yes
SQLite
Yes
TekSIP
No
Integrations
Azure DevOps
No
Dynasoft Telefactura
Yes
GitHub
No
MariaDB
No
MySQL
No
Oracle Database
No
PostgreSQL
No
SQL Server
No
SQLite
No
TekSIP
Yes
Pricing Details
$0
Codayak is free for personal and commercial use, with no subscription or metering. Users provide their own language-model provider API keys and pay those providers for API usage, or use locally hosted models.
Free Trial
No
Free Version
Yes
Pricing Details
$239
Following features are not supported in the free edition.
Enterprise
* EAP-TLS, EAP-TTLS, EAP-SIM and LEAP authentication methods for EAP
* NTLM authentication for MS-CHAP authentication methods (Authentication of Windows domain users)
* Active Directory msRADIUSFramedIPAddress attribute and Dial-in / Verify Called-Id support
* Regular Expression based attribute matching
* OTP (One Time Password, RFC 2289)
* Dynamic IP address assignment using local IP pools or a DHCP server
* Send email notifications for user events
* TLS Transport (RFC 6614) authentication
* OCSP Stapling for EAP authentication methods
* Audit log
SP
* Enterprise features
* VoIP billing
* HTTP reporting and user management interface
* Google Authenticator support
* Alphanumeric RADIUS client entry
* Specifying free usage periods for users
* IPv6 support
* Custom encryption module
* Sending Packet of Disconnect (PoD), * Change of Authorization (CoA), or executing user defined session kill command when a user consumes all credit
* Near quota limit warning
Enterprise
* EAP-TLS, EAP-TTLS, EAP-SIM and LEAP authentication methods for EAP
* NTLM authentication for MS-CHAP authentication methods (Authentication of Windows domain users)
* Active Directory msRADIUSFramedIPAddress attribute and Dial-in / Verify Called-Id support
* Regular Expression based attribute matching
* OTP (One Time Password, RFC 2289)
* Dynamic IP address assignment using local IP pools or a DHCP server
* Send email notifications for user events
* TLS Transport (RFC 6614) authentication
* OCSP Stapling for EAP authentication methods
* Audit log
SP
* Enterprise features
* VoIP billing
* HTTP reporting and user management interface
* Google Authenticator support
* Alphanumeric RADIUS client entry
* Specifying free usage periods for users
* IPv6 support
* Custom encryption module
* Sending Packet of Disconnect (PoD), * Change of Authorization (CoA), or executing user defined session kill command when a user consumes all credit
* Near quota limit warning
Free Trial
Yes
Free Version
Yes
Deployment
Web-Based
No
On-Premises
No
iPhone App
No
iPad App
No
Android App
No
Windows
Yes
Mac
No
Linux
No
Chromebook
No
Deployment
Web-Based
No
On-Premises
Yes
iPhone App
No
iPad App
No
Android App
No
Windows
Yes
Mac
No
Linux
No
Chromebook
No
Customer Support
Business Hours
No
Live Rep (24/7)
No
Online Support
Yes
Customer Support
Business Hours
Yes
Live Rep (24/7)
Yes
Online Support
Yes
Types of Training
Training Docs
Yes
Webinars
No
Live Training (Online)
No
In Person
No
Types of Training
Training Docs
Yes
Webinars
No
Live Training (Online)
No
In Person
No
Vendor Details
Company Name
Techniche Labs Pty Ltd
Founded
2023
Country
Australia
Website
www.technichelabs.com.au/codayak.aspx
Vendor Details
Company Name
KaplanSoft
Founded
2011
Country
Turkey
Website
www.kaplansoft.com
Product Features
Product Features
Network Access Control (NAC)
Authentication
Yes
Authorization
Yes
Automated Hotfix / Updates
No
Centralized Policy Management
Yes
Dashboard
No
Device Auto-Provisioning
No
Device Self-Registration
No
Posture Assessment
No
Quarantine / Remediation
Yes
Secure Guest Access
No